$re = '/[A-Z]{0,2,3}\d+/m';
$str = 'AAA1234
0000123
A000123
AA12345
A{0,2,3}1234
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);