import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*(?P<hop>\\d+)\\s+(?P<probe_1><?[\\d*]*)(\\s*ms)?\\s+(?P<probe_2><?[\\d*]*)(\\s*ms)?\\s*(?P<probe_3><?[\\d*]*)(\\s*ms)?\\s*(?P<dest>([^*[ ]+)|(Request timed out[.]))(\\s*\\[(?P<dest_ip>\\d+\\.\\d+\\.\\d+\\.\\d+)\\])?$";
final String string = " 7 107 ms 84 ms 83 ms gar2.placa.ip.att.net [12.122.110.5]\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}