re = /^\s*(?P<hop>\d+)\s+(?P<probe_1><?[\d*]*)(\s*ms)?\s+(?P<probe_2><?[\d*]*)(\s*ms)?\s*(?P<probe_3><?[\d*]*)(\s*ms)?\s*(?P<dest>([^*[ ]+)|(Request timed out[.]))(\s*\[(?P<dest_ip>\d+\.\d+\.\d+\.\d+)\])?$/
str = ' 7 107 ms 84 ms 83 ms gar2.placa.ip.att.net [12.122.110.5]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end