import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*\\bDocuments\\b).*\\bDownloading view page:(?!\\S).*$";
final String string = "2/27/2020 7:00:43 PM 138 (6036) Downloading view page: /personal/test/Documents/Forms/All.aspx...\n"
+ "2/27/2020 7:00:43 PM 138 (6036) Downloading page WebParts...\n"
+ "2/27/2020 7:00:44 PM 138 (6036) Downloading page web parts completed. 1 web parts successfully downloaded.\n"
+ "2/27/2020 7:00:44 PM 138 (6036) Downloading page content...\n"
+ "2/27/2020 7:00:44 PM 138 (6036) Restarting from position 8312...\n"
+ "2/27/2020 7:00:44 PM 138 (6036) Error: error\n"
+ "double double\n"
+ "2/27/2020 7:00:43 PM 138 (6036) Downloading view page: /personal/test/sdadasda/Forms/All.aspx...\n"
+ "2/27/2020 7:00:44 PM 138 (6036) Error: Unspecified error\n"
+ "2/27/2020 7:00:43 PM 138 (6036) Downloading view page: /personal/test/21312332131/Forms/All.aspx...\n"
+ "2/27/2020 7:00:43 PM 138 (6036) Downloading view page: /personal/test/123/Forms/All.aspx...\n"
+ "2/27/2020 7:00:43 PM 138 (6036) Downloading view page: /personal/test/123/Forms/All.aspx...\n"
+ "2/27/2020 7:00:43 PM 138 (6036) Downloading view page: /personal/test/Documeents/Forms/All.aspx...\n"
+ "2/27/2020 7:00:43 PM 138 (6036) Downloading view page: /personal/test/wr/Forms/All.aspx...";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}