$re = '/^(?!.*\bDocuments\b).*\bDownloading view page:(?!\S).*$/m';
$str = '2/27/2020 7:00:43 PM 138 (6036) Downloading view page: /personal/test/Documents/Forms/All.aspx...
2/27/2020 7:00:43 PM 138 (6036) Downloading page WebParts...
2/27/2020 7:00:44 PM 138 (6036) Downloading page web parts completed. 1 web parts successfully downloaded.
2/27/2020 7:00:44 PM 138 (6036) Downloading page content...
2/27/2020 7:00:44 PM 138 (6036) Restarting from position 8312...
2/27/2020 7:00:44 PM 138 (6036) Error: error
double double
2/27/2020 7:00:43 PM 138 (6036) Downloading view page: /personal/test/sdadasda/Forms/All.aspx...
2/27/2020 7:00:44 PM 138 (6036) Error: Unspecified error
2/27/2020 7:00:43 PM 138 (6036) Downloading view page: /personal/test/21312332131/Forms/All.aspx...
2/27/2020 7:00:43 PM 138 (6036) Downloading view page: /personal/test/123/Forms/All.aspx...
2/27/2020 7:00:43 PM 138 (6036) Downloading view page: /personal/test/123/Forms/All.aspx...
2/27/2020 7:00:43 PM 138 (6036) Downloading view page: /personal/test/Documeents/Forms/All.aspx...
2/27/2020 7:00:43 PM 138 (6036) Downloading view page: /personal/test/wr/Forms/All.aspx...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);