package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?|<(\$)([a-zA-Z0-9]+):([a-zA-Z0-9]+):([a-zA-Z0-9]+)>|{(@)([a-zA-Z0-9 ]+)})`)
var str = `<$abc:def:ghi> {@abc}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}