re = /(?|<(\$)([a-zA-Z0-9]+):([a-zA-Z0-9]+):([a-zA-Z0-9]+)>|{(@)([a-zA-Z0-9 ]+)})/m
str = '<$abc:def:ghi> {@abc}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end