#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b(\d+ abc \d+)\b|\babc\b"
Local $sString = "123 abc (match) " & @CRLF & _
"abc 1234 (match) " & @CRLF & _
"xyz abc (match) " & @CRLF & _
"abc xyz (match) " & @CRLF & _
"xyz32 abc xyz23 (match) " & @CRLF & _
"xyz32 abc 34523 (match) " & @CRLF & _
"1234 abc xyz23 (match) " & @CRLF & _
"12322 abc 1111(pass, we are good)."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")