const regex = /\b(\d+ abc \d+)\b|\babc\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(\\d+ abc \\d+)\\b|\\babc\\b', 'g')
const str = `123 abc (match)
abc 1234 (match)
xyz abc (match)
abc xyz (match)
xyz32 abc xyz23 (match)
xyz32 abc 34523 (match)
1234 abc xyz23 (match)
12322 abc 1111(pass, we are good).`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}