package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-ZÀ-ÿ0-9.\s&\/()\"%-+\[\]\*\$]*$`)
var str = `Chocolate [36 pk]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}