$re = '/^[a-zA-ZÀ-ÿ0-9.\s&\/()\"%-+\[\]\*\$]*$/m';
$str = 'Chocolate [36 pk]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);