using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^(]*\K\(|\)(?!.*\).*)";
string input = @"Foo ( test1 test2 ) bob
Bar ( test1 t3() test2 ) bob
Baz (((""Fdsfds""))) bob";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}