re = /^[^(]*\K\(|\)(?!.*\).*)/m
str = 'Foo ( test1 test2 ) bob
Bar ( test1 t3() test2 ) bob
Baz ((("Fdsfds"))) bob'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end