using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".+(?=\s-|\(|\?|\*)";
string input = @"123 - 456
dskfskghfjgn ( 454t3t53 )
2343543534 ? 454354354
the test * 346345436t3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}