using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?:(?!-my-word).|-my-word(?=.*-my-word))+)";
string input = @"mylaptop-my-word
mylaptop
mylaptop-my-word-hello-my-word";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}