re = /^((?:(?!-my-word).|-my-word(?=.*-my-word))+)/m
str = 'mylaptop-my-word
mylaptop
mylaptop-my-word-hello-my-word'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end