using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\/src\/main\/java(\/[^\/]+)\/\*\.java$";
string input = @"/src/main/java/{any_package}/*.java
/src/main/java/*.java";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}