re = /^\/src\/main\/java(\/[^\/]+)\/\*\.java$/m
str = '/src/main/java/{any_package}/*.java
/src/main/java/*.java'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end