#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<RawData>55014B467FFF0C10BEFF00+<\/RawData>\n\n<PrimaryValue>(\d+.\d+)"
Local $sString = "<?xml version="1.0" encoding="UTF-8"?>" & @CRLF & _
"" & @CRLF & _
"-<Devices-Detail-Response xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://www.embeddeddatasystems.com/schema/owserver">" & @CRLF & _
"" & @CRLF & _
"<PollCount>71</PollCount>" & @CRLF & _
"" & @CRLF & _
"<DevicesConnected>2</DevicesConnected>" & @CRLF & _
"" & @CRLF & _
"<LoopTime>2.048</LoopTime>" & @CRLF & _
"" & @CRLF & _
"<DevicesConnectedChannel1>2</DevicesConnectedChannel1>" & @CRLF & _
"" & @CRLF & _
"<DevicesConnectedChannel2>0</DevicesConnectedChannel2>" & @CRLF & _
"" & @CRLF & _
"<DevicesConnectedChannel3>0</DevicesConnectedChannel3>" & @CRLF & _
"" & @CRLF & _
"<DataErrorsChannel1>0</DataErrorsChannel1>" & @CRLF & _
"" & @CRLF & _
"<DataErrorsChannel2>0</DataErrorsChannel2>" & @CRLF & _
"" & @CRLF & _
"<DataErrorsChannel3>0</DataErrorsChannel3>" & @CRLF & _
"" & @CRLF & _
"<VoltageChannel1>4.81</VoltageChannel1>" & @CRLF & _
"" & @CRLF & _
"<VoltageChannel2>4.81</VoltageChannel2>" & @CRLF & _
"" & @CRLF & _
"<VoltageChannel3>4.80</VoltageChannel3>" & @CRLF & _
"" & @CRLF & _
"<VoltagePower>5.05</VoltagePower>" & @CRLF & _
"" & @CRLF & _
"<DeviceName>OWServer_v2-Enet</DeviceName>" & @CRLF & _
"" & @CRLF & _
"<HostName>EDSOWSERVER2</HostName>" & @CRLF & _
"" & @CRLF & _
"<MACAddress>00:04:A3:BE:A9:F2</MACAddress>" & @CRLF & _
"" & @CRLF & _
"<DateTime>2017-03-10 23:18:40</DateTime>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"-<owd_DS18B20 Description="Programmable resolution thermometer">" & @CRLF & _
"" & @CRLF & _
"<Name>DS18B20</Name>" & @CRLF & _
"" & @CRLF & _
"<Family>28</Family>" & @CRLF & _
"" & @CRLF & _
"<ROMId>690516B3FC14FF28</ROMId>" & @CRLF & _
"" & @CRLF & _
"<Health>7</Health>" & @CRLF & _
"" & @CRLF & _
"<Channel>1</Channel>" & @CRLF & _
"" & @CRLF & _
"<RawData>54014B467FFF0C10FDFF0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000</RawData>" & @CRLF & _
"" & @CRLF & _
"<PrimaryValue>21.2500 Deg C</PrimaryValue>" & @CRLF & _
"" & @CRLF & _
"<Temperature Units="Centigrade">21.2500</Temperature>" & @CRLF & _
"" & @CRLF & _
"<UserByte1 Writable="True">75</UserByte1>" & @CRLF & _
"" & @CRLF & _
"<UserByte2 Writable="True">70</UserByte2>" & @CRLF & _
"" & @CRLF & _
"<Resolution>12</Resolution>" & @CRLF & _
"" & @CRLF & _
"<PowerSource>255</PowerSource>" & @CRLF & _
"" & @CRLF & _
"</owd_DS18B20>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"-<owd_DS18B20 Description="Programmable resolution thermometer">" & @CRLF & _
"" & @CRLF & _
"<Name>DS18B20</Name>" & @CRLF & _
"" & @CRLF & _
"<Family>28</Family>" & @CRLF & _
"" & @CRLF & _
"<ROMId>020316B4A6C3FF28</ROMId>" & @CRLF & _
"" & @CRLF & _
"<Health>7</Health>" & @CRLF & _
"" & @CRLF & _
"<Channel>1</Channel>" & @CRLF & _
"" & @CRLF & _
"<RawData>55014B467FFF0C10BEFF0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000</RawData>" & @CRLF & _
"" & @CRLF & _
"<PrimaryValue>21.3125 Deg C</PrimaryValue>" & @CRLF & _
"" & @CRLF & _
"<Temperature Units="Centigrade">21.3125</Temperature>" & @CRLF & _
"" & @CRLF & _
"<UserByte1 Writable="True">75</UserByte1>" & @CRLF & _
"" & @CRLF & _
"<UserByte2 Writable="True">70</UserByte2>" & @CRLF & _
"" & @CRLF & _
"<Resolution>12</Resolution>" & @CRLF & _
"" & @CRLF & _
"<PowerSource>255</PowerSource>" & @CRLF & _
"" & @CRLF & _
"</owd_DS18B20>" & @CRLF & _
"" & @CRLF & _
"</Devices-Detail-Response>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")