# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<RawData>55014B467FFF0C10BEFF00+<\/RawData>\n\n<PrimaryValue>(\d+.\d+)"
test_str = ("<?xml version=\"1.0\" encoding=\"UTF-8\"?>\n\n"
"-<Devices-Detail-Response xmlns:xsi=\"http://www.w3.org/2001/XMLSchema-instance\" xmlns=\"http://www.embeddeddatasystems.com/schema/owserver\">\n\n"
"<PollCount>71</PollCount>\n\n"
"<DevicesConnected>2</DevicesConnected>\n\n"
"<LoopTime>2.048</LoopTime>\n\n"
"<DevicesConnectedChannel1>2</DevicesConnectedChannel1>\n\n"
"<DevicesConnectedChannel2>0</DevicesConnectedChannel2>\n\n"
"<DevicesConnectedChannel3>0</DevicesConnectedChannel3>\n\n"
"<DataErrorsChannel1>0</DataErrorsChannel1>\n\n"
"<DataErrorsChannel2>0</DataErrorsChannel2>\n\n"
"<DataErrorsChannel3>0</DataErrorsChannel3>\n\n"
"<VoltageChannel1>4.81</VoltageChannel1>\n\n"
"<VoltageChannel2>4.81</VoltageChannel2>\n\n"
"<VoltageChannel3>4.80</VoltageChannel3>\n\n"
"<VoltagePower>5.05</VoltagePower>\n\n"
"<DeviceName>OWServer_v2-Enet</DeviceName>\n\n"
"<HostName>EDSOWSERVER2</HostName>\n\n"
"<MACAddress>00:04:A3:BE:A9:F2</MACAddress>\n\n"
"<DateTime>2017-03-10 23:18:40</DateTime>\n\n\n"
"-<owd_DS18B20 Description=\"Programmable resolution thermometer\">\n\n"
"<Name>DS18B20</Name>\n\n"
"<Family>28</Family>\n\n"
"<ROMId>690516B3FC14FF28</ROMId>\n\n"
"<Health>7</Health>\n\n"
"<Channel>1</Channel>\n\n"
"<RawData>54014B467FFF0C10FDFF0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000</RawData>\n\n"
"<PrimaryValue>21.2500 Deg C</PrimaryValue>\n\n"
"<Temperature Units=\"Centigrade\">21.2500</Temperature>\n\n"
"<UserByte1 Writable=\"True\">75</UserByte1>\n\n"
"<UserByte2 Writable=\"True\">70</UserByte2>\n\n"
"<Resolution>12</Resolution>\n\n"
"<PowerSource>255</PowerSource>\n\n"
"</owd_DS18B20>\n\n\n"
"-<owd_DS18B20 Description=\"Programmable resolution thermometer\">\n\n"
"<Name>DS18B20</Name>\n\n"
"<Family>28</Family>\n\n"
"<ROMId>020316B4A6C3FF28</ROMId>\n\n"
"<Health>7</Health>\n\n"
"<Channel>1</Channel>\n\n"
"<RawData>55014B467FFF0C10BEFF0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000</RawData>\n\n"
"<PrimaryValue>21.3125 Deg C</PrimaryValue>\n\n"
"<Temperature Units=\"Centigrade\">21.3125</Temperature>\n\n"
"<UserByte1 Writable=\"True\">75</UserByte1>\n\n"
"<UserByte2 Writable=\"True\">70</UserByte2>\n\n"
"<Resolution>12</Resolution>\n\n"
"<PowerSource>255</PowerSource>\n\n"
"</owd_DS18B20>\n\n"
"</Devices-Detail-Response>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.