package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?i)(0?[1-9]|[12][0-9]|3[01])? ?(Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec)? ?(\d{4})?$`)
var str = `11
11 jun
11 Jun 2025
2025
6
Jun
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}