re = /^(?i)(0?[1-9]|[12][0-9]|3[01])? ?(Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec)? ?(\d{4})?$/m
str = '11
11 jun
11 Jun 2025
2025
6
Jun
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end