import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:<a class=\"page-numbers[^>]*>(\\d+)<\\/a>\\s*)+";
final String string = "<a class=\"page-numbers\" href=\"https://example.com/page/6/\">6</a>\n"
+ "<a class=\"page-numbers\" href=\"https://example.com/page/7/\">7</a>\n"
+ "<a class=\"page-numbers\" href=\"https://example.com/page/8/\">8</a>\n"
+ "<a class=\"next page-numbers\" href=\"https://example.com/page/49/\">NEXT</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}