const regex = /(?:<a class="page-numbers[^>]*>(\d+)<\/a>\s*)+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:<a class="page-numbers[^>]*>(\\d+)<\\\/a>\\s*)+', 'gm')
const str = `<a class="page-numbers" href="https://example.com/page/6/">6</a>
<a class="page-numbers" href="https://example.com/page/7/">7</a>
<a class="page-numbers" href="https://example.com/page/8/">8</a>
<a class="next page-numbers" href="https://example.com/page/49/">NEXT</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}