package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\bSomebody\b(?:(\bin\b|\blorem\b|\bipsum\b).*|.)*?\bwords\b`)
var str = `Somebody has typed in some words here.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}