re = /\bSomebody\b(?:(\bin\b|\blorem\b|\bipsum\b).*|.)*?\bwords\b/
str = 'Somebody has typed in some words here.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end