import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?(?=#).*\\n(.)|(?(?=.#).*\\n.(.)|(?(?=..#).*\\n..(.)|(?(?=...#).*\\n...(.)|(?(?=^....#).*\\n....(.)|(?(?=^.{5}#).*\\n.{5}(.)|(?(?=^.{6}#).*\\n.{6}(.)|#))))))).*$";
final String string = "#AB\n"
+ "xyz\n"
+ "A#B\n"
+ "xyz\n"
+ "X#ZEAKBLA\n"
+ "123456789\n"
+ "XIZEAK#LA\n"
+ "123456789\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}