const regex = /username\s([a-zA-Z0-9]*)(?>\sprivilege\s([0-9]{1,2}))?.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('username\\s([a-zA-Z0-9]*)(?>\\sprivilege\\s([0-9]{1,2}))?.*', 'gm')
const str = `username ytnflvby secret <hash>
username eec privilege 15 secret <hash>
username protuser privilege 3 password 7 <hash>
username wheel privilege 0 secret <hash>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}