use strict;
my $str = 'username ytnflvby secret <hash>
username eec privilege 15 secret <hash>
username protuser privilege 3 password 7 <hash>
username wheel privilege 0 secret <hash>
';
my $regex = qr/username\s([a-zA-Z0-9]*)(?>\sprivilege\s([0-9]{1,2}))?.*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}