#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?P<major>0|[1-9]\d*)\.(?P<minor>0|[1-9]\d*)(?:\.(?P<feature>0|[1-9]\d*)(?:\.(?P<commit>0|[1-9]\d*))?)?(?:\:(?P<count>0|[1-9]\d*))?(?:-(?P<prerelease>(?:0|[1-9]\d*|\d*[a-zA-Z-][0-9a-zA-Z-]*)(?:\.(?:0|[1-9]\d*|\d*[a-zA-Z-][0-9a-zA-Z-]*))*))?(?:\+(?P<meta>[^~\s]*))?(?:(?P<breaks>\~[^\s]*?))?$"
Local $sString = "Valid Natural Versions" & @CRLF & _
"" & @CRLF & _
"1.2" & @CRLF & _
"1.2.3" & @CRLF & _
"1.2.3.1" & @CRLF & _
"1.2:123" & @CRLF & _
"1.2.3:123" & @CRLF & _
"1.2.3.1:123" & @CRLF & _
"0.0.4.3~a.b.c" & @CRLF & _
"10.20.30.40~" & @CRLF & _
"1.1.2.3-prerelease~a.b,c;d:e+meta" & @CRLF & _
"1.1.2.4+meta" & @CRLF & _
"1.1.2.5+meta-valid" & @CRLF & _
"1.1.2.6-valid+meta" & @CRLF & _
"1.1.2.7-valid~breaks+meta" & @CRLF & _
"1.1.2.4:123+meta" & @CRLF & _
"1.1.2.5:123+meta-valid" & @CRLF & _
"1.1.2.6:123-valid+meta" & @CRLF & _
"1.1.2.7:123-valid~breaks+meta" & @CRLF & _
"1.0.0.0-alpha" & @CRLF & _
"1.0.0.1~beta" & @CRLF & _
"1.0.0.2-alpha.beta" & @CRLF & _
"1.0.0.3-alpha22~beta.1" & @CRLF & _
"1.0.0.4-alpha.1~~foo+bar" & @CRLF & _
"1.0.0.5-alpha0~broken+not" & @CRLF & _
"1.0.0.6-alpha+0.valid" & @CRLF & _
"1.0.0.7-alpha~a.b_c_somethinglong+build.1_aef.1_its_okay" & @CRLF & _
"1.0.0.8-rc.1+build.1" & @CRLF & _
"2.0.0.9-rc.1~a,b,c;d,e,f;g:h,i:j+build.123" & @CRLF & _
"1.2.3.10-beta" & @CRLF & _
"10.2.3.11-DEV-SNAPSHOT" & @CRLF & _
"1.2.3.12-SNAPSHOT-123+123~123" & @CRLF & _
"1.0.0.13" & @CRLF & _
"2.0.0.14" & @CRLF & _
"1.1.7.15" & @CRLF & _
"2.0.0.16+build.1848" & @CRLF & _
"2.0.1.17-alpha.1227" & @CRLF & _
"1.0.0.18-alpha+beta" & @CRLF & _
"1.2.3.19----RC-SNAPSHOT.12.9.1--.12+788" & @CRLF & _
"1.2.3.20----R-S.12.9.1--.12+meta" & @CRLF & _
"1.2.3.21----RC-SNAPSHOT.12.9.1--.12" & @CRLF & _
"1.0.0.22+0.build.1-rc.10000aaa-kk-0.1" & @CRLF & _
"99999999999999999999999.999999999999999999.99999999999999999.999" & @CRLF & _
"1.0.0.23-0A.is.legal" & @CRLF & _
"1.1.2.4+.123" & @CRLF & _
"9.8.7.14+meta+meta" & @CRLF & _
"9.8.7.15-whatever+meta+meta" & @CRLF & _
"1.2~~~foo" & @CRLF & _
"1.2-RC-SNAPSHOT" & @CRLF & _
"1.2+SNAPSHOT" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Invalid Natural Versions" & @CRLF & _
"" & @CRLF & _
"1" & @CRLF & _
"1.2:" & @CRLF & _
"1.2.3.4-0123" & @CRLF & _
"1.2.3.4:-0123" & @CRLF & _
"1.2.3.4-0123.0123" & @CRLF & _
"+invalid" & @CRLF & _
"-invalid" & @CRLF & _
"-invalid+invalid" & @CRLF & _
"-invalid.01" & @CRLF & _
"alpha" & @CRLF & _
"alpha.beta" & @CRLF & _
"alpha.beta.1" & @CRLF & _
"alpha.1" & @CRLF & _
"alpha+beta" & @CRLF & _
"alpha_beta" & @CRLF & _
"alpha." & @CRLF & _
"alpha.." & @CRLF & _
"beta" & @CRLF & _
"1.0.0.1-alpha_beta" & @CRLF & _
"-alpha." & @CRLF & _
"1.0.0.2-alpha.." & @CRLF & _
"1.0.0.3-alpha..1" & @CRLF & _
"1.0.0.4-alpha...1" & @CRLF & _
"1.0.0.5-alpha....1" & @CRLF & _
"1.0.0.6-alpha.....1" & @CRLF & _
"1.0.0.7-alpha......1" & @CRLF & _
"1.0.0.8-alpha.......1" & @CRLF & _
"01.1.1.9" & @CRLF & _
"1.01.1.10" & @CRLF & _
"1.1.01.11" & @CRLF & _
"1.2.3.12.DEV" & @CRLF & _
"1.2.31.2.3----RC-SNAPSHOT.12.09.1--..12+788" & @CRLF & _
"-1.0.3.13-gamma+b7718" & @CRLF & _
"+justmeta" & @CRLF & _
"~just+breaks" & @CRLF & _
"+meta~broken" & @CRLF & _
"-beta+meta~still+broken" & @CRLF & _
"99999999999999999999999.999999999999999999.99999999999999999----RC-SNAPSHOT.12.09.1--------------------------------..12"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")