# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?P<major>0|[1-9]\d*)\.(?P<minor>0|[1-9]\d*)(?:\.(?P<feature>0|[1-9]\d*)(?:\.(?P<commit>0|[1-9]\d*))?)?(?:\:(?P<count>0|[1-9]\d*))?(?:-(?P<prerelease>(?:0|[1-9]\d*|\d*[a-zA-Z-][0-9a-zA-Z-]*)(?:\.(?:0|[1-9]\d*|\d*[a-zA-Z-][0-9a-zA-Z-]*))*))?(?:\+(?P<meta>[^~\s]*))?(?:(?P<breaks>\~[^\s]*?))?$"
test_str = ("Valid Natural Versions\n\n"
"1.2\n"
"1.2.3\n"
"1.2.3.1\n"
"1.2:123\n"
"1.2.3:123\n"
"1.2.3.1:123\n"
"0.0.4.3~a.b.c\n"
"10.20.30.40~\n"
"1.1.2.3-prerelease~a.b,c;d:e+meta\n"
"1.1.2.4+meta\n"
"1.1.2.5+meta-valid\n"
"1.1.2.6-valid+meta\n"
"1.1.2.7-valid~breaks+meta\n"
"1.1.2.4:123+meta\n"
"1.1.2.5:123+meta-valid\n"
"1.1.2.6:123-valid+meta\n"
"1.1.2.7:123-valid~breaks+meta\n"
"1.0.0.0-alpha\n"
"1.0.0.1~beta\n"
"1.0.0.2-alpha.beta\n"
"1.0.0.3-alpha22~beta.1\n"
"1.0.0.4-alpha.1~~foo+bar\n"
"1.0.0.5-alpha0~broken+not\n"
"1.0.0.6-alpha+0.valid\n"
"1.0.0.7-alpha~a.b_c_somethinglong+build.1_aef.1_its_okay\n"
"1.0.0.8-rc.1+build.1\n"
"2.0.0.9-rc.1~a,b,c;d,e,f;g:h,i:j+build.123\n"
"1.2.3.10-beta\n"
"10.2.3.11-DEV-SNAPSHOT\n"
"1.2.3.12-SNAPSHOT-123+123~123\n"
"1.0.0.13\n"
"2.0.0.14\n"
"1.1.7.15\n"
"2.0.0.16+build.1848\n"
"2.0.1.17-alpha.1227\n"
"1.0.0.18-alpha+beta\n"
"1.2.3.19----RC-SNAPSHOT.12.9.1--.12+788\n"
"1.2.3.20----R-S.12.9.1--.12+meta\n"
"1.2.3.21----RC-SNAPSHOT.12.9.1--.12\n"
"1.0.0.22+0.build.1-rc.10000aaa-kk-0.1\n"
"99999999999999999999999.999999999999999999.99999999999999999.999\n"
"1.0.0.23-0A.is.legal\n"
"1.1.2.4+.123\n"
"9.8.7.14+meta+meta\n"
"9.8.7.15-whatever+meta+meta\n"
"1.2~~~foo\n"
"1.2-RC-SNAPSHOT\n"
"1.2+SNAPSHOT\n\n\n"
"Invalid Natural Versions\n\n"
"1\n"
"1.2:\n"
"1.2.3.4-0123\n"
"1.2.3.4:-0123\n"
"1.2.3.4-0123.0123\n"
"+invalid\n"
"-invalid\n"
"-invalid+invalid\n"
"-invalid.01\n"
"alpha\n"
"alpha.beta\n"
"alpha.beta.1\n"
"alpha.1\n"
"alpha+beta\n"
"alpha_beta\n"
"alpha.\n"
"alpha..\n"
"beta\n"
"1.0.0.1-alpha_beta\n"
"-alpha.\n"
"1.0.0.2-alpha..\n"
"1.0.0.3-alpha..1\n"
"1.0.0.4-alpha...1\n"
"1.0.0.5-alpha....1\n"
"1.0.0.6-alpha.....1\n"
"1.0.0.7-alpha......1\n"
"1.0.0.8-alpha.......1\n"
"01.1.1.9\n"
"1.01.1.10\n"
"1.1.01.11\n"
"1.2.3.12.DEV\n"
"1.2.31.2.3----RC-SNAPSHOT.12.09.1--..12+788\n"
"-1.0.3.13-gamma+b7718\n"
"+justmeta\n"
"~just+breaks\n"
"+meta~broken\n"
"-beta+meta~still+broken\n"
"99999999999999999999999.999999999999999999.99999999999999999----RC-SNAPSHOT.12.09.1--------------------------------..12")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.