$re = '/^[a-zA-Z0-9\/]+(?:[\w -]*[a-zA-Z0-9\/]+)*$/m';
$str = 'a
abc
abc
def
abc123
ab_cd
ab-cd
abcd
abcd_
abc-
-def
asdsa-sad/sad';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);