re = /^[a-zA-Z0-9\/]+(?:[\w -]*[a-zA-Z0-9\/]+)*$/m
str = 'a
abc
abc
def
abc123
ab_cd
ab-cd
abcd
abcd_
abc-
-def
asdsa-sad/sad'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end