package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?s).*junkasdojf\s*(:[^:]*:).*`)
var str = `Some string here, junkasdojf :text: and more here`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}