$re = '/(?s).*junkasdojf\s*(:[^:]*:).*/m';
$str = 'Some string here, junkasdojf :text: and more here';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;