package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bz?[^\Wz]\w*?zz\w*[^\Wz]z?\b`)
var str = `lorem ipsum buzz mezzo mix zztop but this is all azzazza azzzzza`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}