re = /\bz?[^\Wz]\w*?zz\w*[^\Wz]z?\b/m
str = 'lorem ipsum buzz mezzo mix zztop but this is all azzazza azzzzza'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end