using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".{0,20}?\bclass\b(?=(.{0,20}))";
string input = @"here is a class and here is another class and some more words";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}