$re = '/.{0,20}?\bclass\b(?=(.{0,20}))/';
$str = 'here is a class and here is another class and some more words';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);