using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(1*01*01*)*";
string input = @"0000
010000101";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}