$re = '/(1*01*01*)*/m';
$str = '0000
010000101';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);