import re
regex = re.compile(r"^(?P<IP>(?:[1-9]|[1-9][0-9]|1[0-9]{2}|2[0-1][0-9]|22[0-3])(?:\.(?:0|[1-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])){3}):(?P<PORT>(?:[1-9]|[1-9][0-9]{1,3}|[1-5][0-9]{4}|6[0-4][0-9]{3}|65[0-4][0-9]{2}|655[0-2][0-9]|6553[0-5]))$", flags=re.MULTILINE)
test_str = ("123.123.123.123:12345\n"
"123.0.123.2:23\n"
"123.01.123.2:23\n"
"123.10.123.2:23\n"
"0.1.2.3:1\n"
"1.0.2.3:1\n"
"223.255.255.255:123\n"
"225.255.255.255:123\n"
"12.231.21.232:65535")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")