using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"({LOOP})(.*?)({ENDLOOP})";
string input = @"{LOOP}
<span>Name %s</span>
{LOOP}
<option value=""%SEL-VL%"">%SEL-TXT%</option>
{ENDLOOP}
{ENDLOOP}";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}