// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms)({LOOP})(.*?)({ENDLOOP})").unwrap();
let string = "{LOOP}
<span>Name %s</span>
{LOOP}
<option value=\"%SEL-VL%\">%SEL-TXT%</option>
{ENDLOOP}
{ENDLOOP}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}