import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<aem_access_remote_ip>\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\.\\d{1,3})\\s(?<aem_access_domain>\\S+)\\s(?<aem_access_user>\\S+)\\s(?<aem_access_date>\\S[^:]+):(?<aem_access_bytes_out>\\S+)\\s(?<aem_access_GMT_offset>[^ ]+)\\s\"(?<aem_access_request_method>[^ ]+)\\s(?<aem_access_request_path>[^ ]+)\\s(?<aem_access_request_protocol>[^ ]+)\"\\s(?<aem_access_status_code>[^ ]+)\\s(?<aem_access_request_duration>[^ ]+)\\s\"(?<aem_access_referrer>[^ ]+)\"\\s\"(?<aem_access_user_agent>.*)\"";
final String string = "104.126.37.30 - mboylce@bim.om 20/Jul/2022:20:10:01 +0200 \"GET /libs/granite/csrf/token.json HTTP/1.1\" 200 103 \"https://cmx-author.win.com/siteadmin\" \"Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/103.0.0.0 Safari/537.36\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}