import Foundation
let pattern = #"^(?<aem_access_remote_ip>\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})\s(?<aem_access_domain>\S+)\s(?<aem_access_user>\S+)\s(?<aem_access_date>\S[^:]+):(?<aem_access_bytes_out>\S+)\s(?<aem_access_GMT_offset>[^ ]+)\s"(?<aem_access_request_method>[^ ]+)\s(?<aem_access_request_path>[^ ]+)\s(?<aem_access_request_protocol>[^ ]+)"\s(?<aem_access_status_code>[^ ]+)\s(?<aem_access_request_duration>[^ ]+)\s"(?<aem_access_referrer>[^ ]+)"\s"(?<aem_access_user_agent>.*)""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"104.126.37.30 - mboylce@bim.om 20/Jul/2022:20:10:01 +0200 "GET /libs/granite/csrf/token.json HTTP/1.1" 200 103 "https://cmx-author.win.com/siteadmin" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/103.0.0.0 Safari/537.36""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)