#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(sudo)(?:\[\d+\])?\:\s+(?:\[[^]]+]\s+)?(\S+)\s*\:\s*TTY=([^ ;]+)\s*;\s*PWD=([^ ;]+)\s*;\s*USER=([^ ;]+)\s*;\s*COMMAND=([^\"]+)"
Local $sString = "{"xif_srcip":"10.0.252.164","sl_fac":"authpriv","sl_sev":"notice","sl_pri":"85","sl_h":"security-alerts-test-1","message":"sudo: root : TTY=pts/4 ; PWD=/root ; USER=root ; COMMAND=/sbin/insmod","ident":"sudo","xif_pfx":"syslog","xif_fwdr":"security-fluentd-iad01-ppd-01.us-east-1a.preprod.ntnxi.net","xif_fwdrip":"10.254.0.6","xih_s":"_","xif_tag":"syslog.authpriv","time":"2019-07-17T20:25:45.700914000Z"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")