$re = '/^\n?(#)[^#\n]+\n|(#)[^#\n]+(#)\n/';
$str = '#namewewwfe ewf e
#naee ewweeweeme#
naewrewrwe me#
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);