re = /^\n?(#)[^#\n]+\n|(#)[^#\n]+(#)\n/
str = '#namewewwfe ewf e
#naee ewweeweeme#
naewrewrwe me#
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end