$re = '~@[\h\pL]+\(([^)]+)\)\h\{([^}]+)\}\K~m';
$str = '@loop (<ВЗЯТЬ ПЕРВЫЙ ТЕКCТ>) {<ВЗЯТЬ ВТОРОЙ ТЕКCТ>}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);